マウスのPCでMac

ビデオの取り込みで使っていた初代MacPro。安定して問題ないのだが、電気喰いなのが致命的。アイドルでも何100ワットとか。これパソコンじゃなくてワークステーションなんよね。動画のエンコは遅くても電気喰わないMacMiniとWindows10のPCで少しづつやってる現状。そんなこんなで魔が差してまだ使えそうな中古PCを購入。ヤフオクで適当に入札。

マウスコンピュータ製 MDV-GZ7000S-SH-W7 。初めての水冷に期待。スペックはCPU:Core i7-4770 3.4GHz メモリ:8GBってことでMacBookProよりも速いはず。ブルーレイもついてるし。GPUが抜かれてるのが気に入らんけど。

ビデオキャプチャにはBlackMagicのIntensity(無印)をそのまま使うとして、OSにはUbuntuかな。このカードはWindows/Mac/Linux全部対応らしいので、それも試してあそべるかなと。

まずはUbuntu18.04で試す。使えない…。ドライバの相性かと取っ替え引っ替え。でもだめ。OSを16.04に落とすが、それでもだめ。どうすっかな〜。

次の手はMac。HackintoshとかOSX86とか呼ばれてる。昔ネットブックで試してしばらく遊んだけど、本物には勝てなかった記憶。今回はハードの性能が高いから大丈夫かと。まずは最新のCatalinaは外して安定のMojave。UnibeastとMultiBeastのお世話になって簡単インストール。のはずが、意外にてこずる。初めてのUEFIマザーボードでBIOSの設定がさっぱり。Unibeastで作ったUSBメモリがUEFIじゃないと動いてくれなくて、GeforceGT630(UEFIでは動かない)を外して内蔵GPU(インテル4600)に切り替えて無事完了。内蔵メモリを喰うこと以外はこっちのが性能よさそう。このマシンのマザーはMSIのZ87-S01とかいうOEM製でUEFIっていってもテキストベースの味もそっけもないもの。Windows8なんちゃらってのを有効にしてやるとモードが変わる。セキュアブートとファーストブートってのは無効にする。で、Intensityを確認するもやっぱりダメ。もしかしてとGPUを外して空いたPCIe3.0x16のスロットに刺すと、いけた~。PCIex1とPCIe2.0x16では画面がちらちらして帯域足りてないような感じ。IntensityはPCIex1でいいはずなんだけどね。この辺がよくわからん。他の機能と排他になってるのか、スロットがこわれてるのか。

取り敢えず、BlackMagicのMediaExpressは動いたが、これではタイマー録画が出来ない。MacProのLionで使ってたBear’sHandが使いたい。ところが、Mojaveでは動作しないのでElCapitanが必要。追加でインストール。マルチブートでさらにぐちゃぐちゃ。EFIにMojave用のモジュールが入ってるのでElCapitan用のMultiBeastが動かない感じ。パッケージ開いて、Etherは個別で入れて動作。サウンドがうまくいかないのでMojave用MultiBeastからもってくると音が出た。スリープは使わないからほっとこ。で、Bear’sHandも動作。BlackMagicのドライバーが10.9くらいからProRessコーデックも内包してくれるんだが、これがBear’sHandで使用できない。MediaExpress専用なのかな。ドライバーを10.8に落として、別にProRessコーデックを/Libraries/QuickTimeに入れてやれば動作。

これで使える環境は出来た。HandBreakのエンコードでMacProが30fpsくらいのとこを50fpsいけるからまずますの性能かな。新しいGPU使えばもっと速いんだろうけど、電気喰うからほどほどでいいか。

PCIe問題の調査。Intensityに問題があるとして、PCIe2.0x16にGeforceGT630を刺すとどうなる?そのためにはUEFIをBIOSモードにする必要がある。UniBeastでは動かなかったが、インストールしてしまえば問題ないみたい。MacOSからはGeforceは認識される。実際にモニターにつなぐと表示されない。やはりスロットの問題なのか?

MacProに繋いでいたHDDを2台移動して合計3台。SATAは6台繋げるから余裕。のはずが…。電源落ちるやんか!普通に動いてるふりして突然ダウン。500Wでたらんのか?MacProは1000Wあったもんな〜

Amazonで750Wの電源を買った。でも届く前にもう一度悪あがきする。SATAケーブルの問題。古いSATA1のケーブルでも実際は問題なくSATA3で使えるらしいのだが、たまに相性が悪いのがあるらしい。HDD2台の問題ない状態でケーブルを交換する。あらら、落ちちゃった。ってことはケーブル?せっかく電源買ったのに?

翌日になると再び発生。SATAケーブルじゃないのか?届いた新品の電源に交換。750Wあるから容量は余裕でしょ。取り敢えずHDDを3台乗せて試すが、今の所正常。明日は4台目に挑戦。

その後、BIOSの変更(古いのしかマウスにない?)をしてみたが、相変わらずIntensityはPCIe3.0x16のスロットでしか使えない。試しにGeforceGT630をPCIe2.0x16に刺すと問題なく動作。ってことはマザーの問題じゃない?単なる相性なのかも…。

消費電力が気になるので調べると、MacPro(初代)はアイドルで250wのベンチマークで400w。Core i7 4770だとアイドル50wでベンチマークが150w。なんじゃこりゃ!